aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2018-11-29 13:12:43 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-11-30 17:44:40 +0000
commitd9dc8ef258ed2ddeeca83775eee945dbfdae59c5 (patch)
treed2a8853847e48925c0ecbb82e58be0a3e52a6e36 /src/CMakeLists.txt
parentc5b67725974af99e50fa5dc02843c7d741add880 (diff)
Migrates bindings v3
This patch migrates biding API of WM to v3. Change-Id: I2f2b23a8af437a414e2a00d629d3e72d0614eb72 Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d2b16ae..fc19a18 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -56,7 +56,7 @@ target_link_libraries(${TARGETS_WM}
target_compile_definitions(${TARGETS_WM}
PRIVATE
- AFB_BINDING_VERSION=2
+ AFB_BINDING_VERSION=3
# We do not want source location of messages
AFB_BINDING_PRAGMA_NO_VERBOSE_DETAILS
WINMAN_VERSION_STRING="${PACKAGE_VERSION}"
@@ -70,7 +70,7 @@ endif()
target_compile_options(${TARGETS_WM}
PRIVATE
- -Wall -Wextra -Wno-unused-parameter -Wno-comment)
+ -Wall -Wextra -Wno-unused-parameter -Wno-comment -Wno-missing-field-initializers)
set_target_properties(${TARGETS_WM}
PROPERTIES