aboutsummaryrefslogtreecommitdiffstats
path: root/policy_manager/stm/zipc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'policy_manager/stm/zipc/CMakeLists.txt')
-rw-r--r--policy_manager/stm/zipc/CMakeLists.txt18
1 files changed, 17 insertions, 1 deletions
diff --git a/policy_manager/stm/zipc/CMakeLists.txt b/policy_manager/stm/zipc/CMakeLists.txt
index 76a2109..b162298 100644
--- a/policy_manager/stm/zipc/CMakeLists.txt
+++ b/policy_manager/stm/zipc/CMakeLists.txt
@@ -31,10 +31,14 @@ set(ST_DIR_LSB ${ST_DIR}/LightStatusBrake)
set(ST_DIR_MST_AL ${ST_DIR}/master/layer/apps)
set(ST_DIR_MST_RMT ${ST_DIR}/master/layer/remote)
+set(ST_DIR_HUD_AL ${ST_DIR}/hud/layer/apps)
+set(ST_DIR_HUD_NA ${ST_DIR}/hud/layer/near_apps)
set(ST_DIR_RMT_HUD ${ST_DIR}/hud/layer/remote_hud)
set(ST_DIR_RMT_HUD_UL ${ST_DIR}/hud/layer/remote_hud_upper_left)
+set(ST_DIR_RSE1_AL ${ST_DIR}/rse1/layer/apps)
set(ST_DIR_RMT_RSE1 ${ST_DIR}/rse1/layer/remote_rse1)
+set(ST_DIR_RSE2_AL ${ST_DIR}/rse2/layer/apps)
set(ST_DIR_RMT_RSE2 ${ST_DIR}/rse2/layer/remote_rse2)
add_library(${TARGETS_STM}
@@ -63,12 +67,20 @@ add_library(${TARGETS_STM}
./stm_master_remote.c
${ST_DIR_MST_AL}/Zmaster_apps_apps_main.c
${ST_DIR_MST_RMT}/Zmaster_remote_remote.c
+ ${ST_DIR_HUD_AL}/Zhud_apps_hud_apps.c
+ ${ST_DIR_HUD_AL}/Zhud_apps_hud_apps_func.c
+ ${ST_DIR_HUD_NA}/Zhud_near_apps_hud_near_apps.c
+ ${ST_DIR_HUD_NA}/Zhud_near_apps_hud_near_apps_func.c
${ST_DIR_RMT_HUD}/Zremote_hud_remote_hud.c
${ST_DIR_RMT_HUD}/Zremote_hud_remote_hud_func.c
${ST_DIR_RMT_HUD_UL}/Zremote_hud_upper_left_remote_hud_up_left.c
${ST_DIR_RMT_HUD_UL}/Zremote_hud_upper_left_remote_hud_up_left_func.c
+ ${ST_DIR_RSE1_AL}/Zrse1_apps_rse1_apps.c
+ ${ST_DIR_RSE1_AL}/Zrse1_apps_rse1_apps_func.c
${ST_DIR_RMT_RSE1}/Zremote_rse1_remote_rse1.c
${ST_DIR_RMT_RSE1}/Zremote_rse1_remote_rse1_func.c
+ ${ST_DIR_RSE2_AL}/Zrse2_apps_rse2_apps.c
+ ${ST_DIR_RSE2_AL}/Zrse2_apps_rse2_apps_func.c
${ST_DIR_RMT_RSE2}/Zremote_rse2_remote_rse2.c
${ST_DIR_RMT_RSE2}/Zremote_rse2_remote_rse2_func.c
)
@@ -88,10 +100,14 @@ target_include_directories(${TARGETS_STM}
./${ST_DIR_LSB}
./${ST_DIR_MST_AL}
./${ST_DIR_MST_RMT}
+ ./${ST_DIR_HUD_AL}
+ ./${ST_DIR_HUD_AL_UL}
./${ST_DIR_RMT_HUD}
./${ST_DIR_RMT_HUD_UL}
+ ./${ST_DIR_RSE1_AL}
+ ./${ST_DIR_RMT_RSE1}
+ ./${ST_DIR_RSE2_AL}
./${ST_DIR_RMT_RSE1}
- ./${ST_DIR_RMT_RSE2}
./${ST_DIR_CMN}
)