summaryrefslogtreecommitdiffstats
path: root/xds-service/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Douheret <sebastien.douheret@iot.bzh>2018-05-24 15:48:18 +0200
committerSebastien Douheret <sebastien.douheret@iot.bzh>2018-07-10 23:59:54 +0200
commit197d9acab4fb5097d3dce56227c2096abdc075bd (patch)
tree6da888c3fa96ccd070939958a4297f140e75b660 /xds-service/CMakeLists.txt
parent1ed3d346f61d9115fccb33d3047be783a7dd7f7a (diff)
Convert binding to use the controller
Change-Id: Iae15b07ee768584d7a1a958fb7e119bca65c29e4 Signed-off-by: Sebastien Douheret <sebastien.douheret@iot.bzh>
Diffstat (limited to 'xds-service/CMakeLists.txt')
-rw-r--r--xds-service/CMakeLists.txt42
1 files changed, 0 insertions, 42 deletions
diff --git a/xds-service/CMakeLists.txt b/xds-service/CMakeLists.txt
deleted file mode 100644
index 9ce0b81..0000000
--- a/xds-service/CMakeLists.txt
+++ /dev/null
@@ -1,42 +0,0 @@
-###########################################################################
-# Copyright 2018 IoT.bzh
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-# Add target to project dependency list
-PROJECT_TARGET_ADD(xds-service)
-
- # Define project Targets
- file(GLOB sourcelist "*.c")
-
- # Define project Targets
- ADD_LIBRARY(${TARGET_NAME} MODULE ${sourcelist})
-
- target_compile_options(${TARGET_NAME}
- PUBLIC -Wno-unused-variable
- )
-
-
- # Binder exposes a unique public entry point
- SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- PREFIX "afb-"
- LABELS "BINDINGV2"
- LINK_FLAGS ${BINDINGS_LINK_FLAG}
- OUTPUT_NAME ${TARGET_NAME}
- )
-
- TARGET_LINK_LIBRARIES(${TARGET_NAME}
- afb-helpers
- ${link_libraries}
- )