summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2018-07-19 14:09:59 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2018-07-23 16:12:13 +0000
commit55673d50338f041763e6e38f38ea3fc311f2bdc1 (patch)
tree9187738d00354dd3d33f62f9f5114c7704a28d42 /CMakeLists.txt
parentf80ab1e0739a5e8694537c4d44b5ab568fa235b4 (diff)
Add simple tests about waiting a group of events.flounder_5.99.2flounder/5.99.25.99.2
Change-Id: I409f8a07806f613e74cf86d6d001f7762eab7f96 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6f19ba5..c533f0e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,4 +18,12 @@
CMAKE_MINIMUM_REQUIRED(VERSION 3.7)
+include(CTest)
+enable_testing()
+
include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)
+
+ADD_TEST(NAME AFT_TESTS
+ WORKING_DIRECTORY ${CMAKE_BINARY_DIR}
+ COMMAND afb-test -v test
+)