summaryrefslogtreecommitdiffstats
path: root/conf.d/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2018-07-05 18:44:42 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2018-07-10 17:12:30 +0200
commit6cdb2c5de8fe343757babb4b758f256cb01d51d5 (patch)
tree7ed09316d6a3d3de718be37d874d0a62f2a04580 /conf.d/CMakeLists.txt
parent90e56dd22eba15bf71e3e0042080c2213ae39920 (diff)
Added a pkgconfig file with the project
Goal is to provide a file to get binding installation path easily from other bindings and be able to use it Change-Id: I09025cfcc568b517da7e48b5a96dece64426f81f Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'conf.d/CMakeLists.txt')
-rw-r--r--conf.d/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/conf.d/CMakeLists.txt b/conf.d/CMakeLists.txt
index 28a0609..3fd4d3c 100644
--- a/conf.d/CMakeLists.txt
+++ b/conf.d/CMakeLists.txt
@@ -20,3 +20,11 @@
# Include any directory not starting with _
# -----------------------------------------------------
PROJECT_SUBDIRS_ADD(${PROJECT_SRC_DIR_PATTERN})
+
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/aft.pc.in ${CMAKE_CURRENT_BINARY_DIR}/aft.pc @ONLY)
+
+INSTALL(FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/aft.pc
+ DESTINATION
+ ${CMAKE_INSTALL_LIBDIR}/pkgconfig
+ )