summaryrefslogtreecommitdiffstats
path: root/conf.d/project/data/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2018-05-17 02:32:11 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2018-07-10 17:12:13 +0200
commitfd65ad40cb1a1b52b5207d45a58962b5f590046b (patch)
treee4672ca39036955444b76ca27f1246be0509255f /conf.d/project/data/CMakeLists.txt
parent63df935362a9c25553696d72ce85089f5a1c7ed0 (diff)
Adding more material to do tests
Make the lua interpreter find the luaunit module. Find a way to use it from the controller. Adding canreplayer file and write a script that could launch in background the canplayer. No process handling by now which have to done in the next step Change-Id: I2d35472ba0e2fbb03ead121ff2587d831fe4ff17 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'conf.d/project/data/CMakeLists.txt')
-rw-r--r--conf.d/project/data/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/conf.d/project/data/CMakeLists.txt b/conf.d/project/data/CMakeLists.txt
new file mode 100644
index 0000000..c545e65
--- /dev/null
+++ b/conf.d/project/data/CMakeLists.txt
@@ -0,0 +1,32 @@
+###########################################################################
+# Copyright 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+
+##################################################
+# Soft Mixer Lua Scripts
+##################################################
+PROJECT_TARGET_ADD(low-can-data)
+
+ file(GLOB CAN_DATA "*.canreplay" "*.sh")
+
+ add_input_files("${CAN_DATA}")
+
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "DATA"
+ OUTPUT_NAME ${TARGET_NAME}
+ )