summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2018-08-28 13:26:37 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-08-30 14:52:41 +0000
commit82c8c5fa4eea15a374fbfde8507ffb09858d4352 (patch)
tree1417cd5547fc7a0cc24fffcc2a2812ffe3983a50 /test/CMakeLists.txt
parente68181541d8dd6d0ca43d8cba7692997cbc26b6a (diff)
Make afTest test itself correctly
For native build and test purposes you need to start 2 bindings to be able to test correctly the afb-test binding. The first one will answer on the main API name afTest and the second to launch the test. This is the closest test case similar to a test on a target board. Change-Id: I6b961c0e41cdd3eef387b7f5156ed334e8f6c3de Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 0c42261..94dca38 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -21,7 +21,7 @@
# -----------------------------------------------------
PROJECT_SUBDIRS_ADD(${PROJECT_SRC_DIR_PATTERN})
-ADD_TEST(NAME AGL_SERVICE_CAN_LOW_LEVEL_TESTS
+ADD_TEST(NAME AFB-TEST_TESTS
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
- COMMAND afb-test.sh ${CMAKE_BINARY_DIR}
+ COMMAND afb-test.sh "${CMAKE_BINARY_DIR}"
)