aboutsummaryrefslogtreecommitdiffstats
path: root/ctl-lib/CMakeLists.txt
diff options
context:
space:
mode:
authorFulup Ar Foll <fulup@iot.bzh>2017-09-29 14:27:43 +0200
committerFulup Ar Foll <fulup@iot.bzh>2017-09-29 14:27:43 +0200
commitb5e1a39b033b422b2cdeb34bda2ed593e30d39e8 (patch)
treefed98530be3f8e9fafb95609f7c3a6b03c24da6e /ctl-lib/CMakeLists.txt
parentf26ce0a65b6cd3c9d7d74f6c79e7c3a932b00d86 (diff)
Remove Netbeans
Diffstat (limited to 'ctl-lib/CMakeLists.txt')
-rw-r--r--ctl-lib/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/ctl-lib/CMakeLists.txt b/ctl-lib/CMakeLists.txt
new file mode 100644
index 0000000..b3d0c32
--- /dev/null
+++ b/ctl-lib/CMakeLists.txt
@@ -0,0 +1,44 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+# Include LUA only when requested
+if(CONTROL_SUPPORT_LUA)
+ message(STATUS "Notice: LUA Controler Support Selected")
+ set(CTL_LUA_SOURCE ctl-lua.c ctl-timer.c)
+ ADD_COMPILE_OPTIONS(-DCONTROL_SUPPORT_LUA)
+else(CONTROL_SUPPORT_LUA)
+ message(STATUS "Warning: LUA Without Support ")
+endif(CONTROL_SUPPORT_LUA)
+
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(afb-controller)
+
+ # Define project Targets
+ ADD_LIBRARY(${TARGET_NAME} STATIC ctl-action.c ctl-config.c ctl-onload.c ctl-plugin.c ${CTL_LUA_SOURCE})
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ afb-utilities
+ )
+
+ # Define target includes for this target client
+ TARGET_INCLUDE_DIRECTORIES(${TARGET_NAME}
+ PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}
+ )
+