summaryrefslogtreecommitdiffstats
path: root/conf.d/packaging/agl-afb-controller.spec
diff options
context:
space:
mode:
Diffstat (limited to 'conf.d/packaging/agl-afb-controller.spec')
-rw-r--r--conf.d/packaging/agl-afb-controller.spec68
1 files changed, 0 insertions, 68 deletions
diff --git a/conf.d/packaging/agl-afb-controller.spec b/conf.d/packaging/agl-afb-controller.spec
deleted file mode 100644
index a3e9478..0000000
--- a/conf.d/packaging/agl-afb-controller.spec
+++ /dev/null
@@ -1,68 +0,0 @@
-###########################################################################
-# Copyright 2015, 2016, 2017 IoT.bzh
-#
-# author: Fulup Ar Foll <fulup@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-
-Name: agl-afb-controller
-Version: 1.0
-Release: 1
-Group: AGL
-License: APL2.0
-Summary: Create controls that could be mapped to LUA functions, callback or API/VERB methods.
-Url: https://github.com/iotbzh/controller-binding
-Source0: %{name}_%{version}.orig.tar.gz
-
-BuildRequires: cmake
-BuildRequires: gcc gcc-c++
-BuildRequires: pkgconfig(json-c)
-BuildRequires: pkgconfig(libsystemd) >= 222
-BuildRequires: pkgconfig(afb-daemon)
-BuildRequires: pkgconfig(libmicrohttpd) >= 0.9.55
-BuildRequires: pkgconfig(libafbwsc)
-BuildRequires: pkgconfig(lua) >= 5.3
-
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-build
-
-%define _prefix /opt/AGL/afb-controller
-%define __cmake cmake
-
-%description
-Create controls that could be mapped to LUA functions, callback or API/VERB methods.
-
-%prep
-%setup -q
-
-%build
-%cmake -DCMAKE_INSTALL_PREFIX:PATH=%{_libdir}
-make %{?_smp_mflags}
-
-%install
-CURDIR=$(pwd)
-[ -d build ] && cd build
-make populate
-mkdir -p %{?buildroot}%{_prefix}
-cp -r package/* %{?buildroot}%{_prefix}
-
-cd $CURDIR
-find %{?buildroot}%{_prefix} -type d -exec echo "%dir {}" \;>> pkg_file
-find %{?buildroot}%{_prefix} -type f -exec echo "{}" \;>> pkg_file
-sed -i 's@%{?buildroot}@@g' pkg_file
-
-
-%files -f pkg_file
-%defattr(-,root,root)