summaryrefslogtreecommitdiffstats
path: root/examples/html5/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-05-02 19:47:36 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2017-05-02 19:47:36 +0200
commit64ffd7a9f9604805c01f8bb2fd32616c3adf3ec0 (patch)
tree264e2743e509b8d7993bc5550ce6140dfc4b151f /examples/html5/CMakeLists.txt
parent6d75b83627114cecd7992bb460f6908268a57967 (diff)
Initial commit
Change-Id: I536251add63ef100b42a67e39a02fef117f2b414 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'examples/html5/CMakeLists.txt')
-rw-r--r--examples/html5/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/examples/html5/CMakeLists.txt b/examples/html5/CMakeLists.txt
new file mode 100644
index 0000000..2a7b33a
--- /dev/null
+++ b/examples/html5/CMakeLists.txt
@@ -0,0 +1,45 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Romain Forlot <romain.forlot@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
+
+include(${CMAKE_CURRENT_SOURCE_DIR}/etc/config.cmake)
+include(${CMAKE_CURRENT_SOURCE_DIR}/etc/macros.cmake)
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(html5-example)
+
+ # Define project Targets
+ add_custom_command(OUTPUT dist.prod
+ DEPENDS ${TARGET_NAME}
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+ COMMAND npm install
+ COMMAND gulp widget-config-prod
+ COMMAND cp -r dist.prod ${CMAKE_CURRENT_BINARY_DIR})
+
+ add_custom_target(${TARGET_NAME} ALL DEPENDS dist.prod)
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ PREFIX ""
+ LABELS "HTDOCS"
+ OUTPUT_NAME dist.prod)
+
+populate_widget()
+
+build_widget()