summaryrefslogtreecommitdiffstats
path: root/templates/hybrid-html5/app/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-05-18 17:49:35 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2017-05-18 17:49:35 +0200
commit162d50a33b8c72d09bd3dc82967c36d559f8278f (patch)
tree337b11ad4c7a9bfa9de46cde0a84a08411043845 /templates/hybrid-html5/app/CMakeLists.txt
parent6993026755563379e964966ee7fc73923a21828d (diff)
Git repo can be used as submodules
Clean templates files as they are useless for usage in submodules into a project. Change-Id: I24c71b64ab2b3a958494f3f190c014227a1da576 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'templates/hybrid-html5/app/CMakeLists.txt')
-rw-r--r--templates/hybrid-html5/app/CMakeLists.txt51
1 files changed, 0 insertions, 51 deletions
diff --git a/templates/hybrid-html5/app/CMakeLists.txt b/templates/hybrid-html5/app/CMakeLists.txt
deleted file mode 100644
index eb70a1b..0000000
--- a/templates/hybrid-html5/app/CMakeLists.txt
+++ /dev/null
@@ -1,51 +0,0 @@
-###########################################################################
-# Copyright 2015, 2016, 2017 IoT.bzh
-#
-# author: Romain Forlot <romain.forlot@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-# Project target list
-# --------------------
-# Add target to project dependency list. Name specified as argument will be
-# added to the project target list and the variable ${TARGET_NAME} become
-# available with that value.
-PROJECT_TARGET_ADD(hybrid-html5-example)
-
- # Define project Targets
- add_custom_command(OUTPUT dist.prod
- DEPENDS ${TARGET_NAME}
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
- COMMAND [ -d app/dist.prod ] && npm install
- COMMAND [ -d app/dist.prod ] && gulp widget-config-prod
- COMMAND cp -r dist.prod ${CMAKE_CURRENT_BINARY_DIR})
-
- add_custom_target(${TARGET_NAME} ALL DEPENDS dist.prod)
-
- # Targets properties
- # ------------------
- # Target properties will be used to build package tree that will be
- # built using project_package_build.
- # OUTPUT_NAME: Depends what is the name of your output file, it is
- # mandatory to specify which is its name with target the property
- # OUTPUT_NAME for your target. If file name is same of your target then
- # use variable ${TARGET_NAME}.
- # LABELS: Choose between "BINDING", "HTDOCS", "EXECUTABLE" depending of
- # the type of your target.
- # PREFIX: This prefix will be added on the output file name specify with
- # OUTPUT_NAME. By default, there isn't PREFIX on target except on
- # library target with is "lib".
- SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- LABELS "HTDOCS"
- OUTPUT_NAME dist.prod)