summaryrefslogtreecommitdiffstats
path: root/templates/service/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-05-04 13:59:00 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2017-05-04 13:59:00 +0200
commit5a87b82700a736e7c443023399da3d2a31098895 (patch)
tree66c306b27d3c61b362536d334ec283b912f5dd67 /templates/service/CMakeLists.txt
parent437f25048ab184e532059f3d31fcf47011abe9fe (diff)
Rename to more meaningful name directories
Change-Id: Ib3990308c1f2358b3e330cd0068719098c4dab56 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'templates/service/CMakeLists.txt')
-rw-r--r--templates/service/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/templates/service/CMakeLists.txt b/templates/service/CMakeLists.txt
new file mode 100644
index 0000000..ea06ed0
--- /dev/null
+++ b/templates/service/CMakeLists.txt
@@ -0,0 +1,40 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Romain Forlot <romain.forlot@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
+
+include(${CMAKE_CURRENT_SOURCE_DIR}/etc/config.cmake)
+include(${CMAKE_CURRENT_SOURCE_DIR}/etc/macros.cmake)
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(service-example)
+
+ # Define project Targets
+ add_library(${TARGET_NAME} MODULE
+ binding/xxxxxx-service-binding.c
+ )
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ PREFIX ""
+ LABELS "BINDING"
+ OUTPUT_NAME ${TARGET_NAME})
+
+populate_widget()
+
+build_widget()