summaryrefslogtreecommitdiffstats
path: root/examples/html5/app/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/html5/app/CMakeLists.txt')
-rw-r--r--examples/html5/app/CMakeLists.txt38
1 files changed, 0 insertions, 38 deletions
diff --git a/examples/html5/app/CMakeLists.txt b/examples/html5/app/CMakeLists.txt
deleted file mode 100644
index ec66f01..0000000
--- a/examples/html5/app/CMakeLists.txt
+++ /dev/null
@@ -1,38 +0,0 @@
-###########################################################################
-# Copyright 2015, 2016, 2017 IoT.bzh
-#
-# author: Romain Forlot <romain.forlot@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-# Add target to project dependency list
-PROJECT_TARGET_ADD(html5-example)
-
- # Define project Targets
- add_custom_command(OUTPUT dist.prod
- DEPENDS ${TARGET_NAME}
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
- COMMAND npm install
- COMMAND gulp widget-config-prod
- COMMAND cp -r dist.prod ${CMAKE_CURRENT_BINARY_DIR})
-
- add_custom_target(${TARGET_NAME} ALL DEPENDS dist.prod)
-
- # Binder exposes a unique public entry point
- SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- PREFIX ""
- LABELS "HTDOCS"
- OUTPUT_NAME dist.prod)
-
-populate_widget()