summaryrefslogtreecommitdiffstats
path: root/templates/native/app/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'templates/native/app/CMakeLists.txt')
-rw-r--r--templates/native/app/CMakeLists.txt51
1 files changed, 51 insertions, 0 deletions
diff --git a/templates/native/app/CMakeLists.txt b/templates/native/app/CMakeLists.txt
new file mode 100644
index 0000000..5a9fa63
--- /dev/null
+++ b/templates/native/app/CMakeLists.txt
@@ -0,0 +1,51 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+# contrib: Romain Forlot <romain.forlot@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(xxx-native-app)
+
+ # Define project Targets
+ add_executable(${TARGET_NAME}
+ ${TARGET_NAME}.c
+ )
+
+ link_libraries(
+ ${CMAKE_THREAD_LIBS_INIT}
+ ${libafbwsc_LIBRARIES}
+ ${json-c_LIBRARIES}
+ ${libsystemd_LIBRARIES}
+ )
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "EXECUTABLE"
+ OUTPUT_NAME ${TARGET_NAME})
+
+ TARGET_INCLUDE_DIRECTORIES(${TARGET_NAME}
+ PUBLIC ${libafbwsc_INCLUDE_DIRS}
+ ${json-c_INCLUDE_DIRS}
+ ${libsystemd_INCLUDE_DIRS})
+
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ afbwsc
+ ${link_libraries})
+
+ # installation directory
+ INSTALL(TARGETS ${TARGET_NAME}
+ RUNTIME DESTINATION ${BINDINGS_INSTALL_DIR})