summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2021-03-02 18:30:32 +0200
committerMarius Vlad <marius.vlad@collabora.com>2021-03-03 13:29:39 +0200
commitb89e581a2fab177e79d64b5990a464683eac49fa (patch)
tree67b289f621a34ecba93c50d7561199d56a9bda93 /CMakeLists.txt
parent99188584dda7a3f83b4cbbb34b11cf4361d23248 (diff)
Bug-AGL: SPEC-3629 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: Ib1a221f03dfac3114bbd3477dc488dd90c86ba35
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..50cee76
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,19 @@
+# Copyright 2021 Collabora, Ltd.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
+
+project(camera-gstreamer)
+include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)