summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-06-25 12:51:41 -0400
committerScott Murray <scott.murray@konsulko.com>2020-06-25 12:56:03 -0400
commit9f2486f3517c81c30a0ef66285cd48ab105442f4 (patch)
treec6d189ba912065a9ccea95c37d352c9ffcecccf4 /CMakeLists.txt
parent4ee878dd42a3af74ad454505a8feb6e120e48d36 (diff)
Fix some build and packaging issuesjellyfish_9.99.1jellyfish/9.99.19.99.1
Fixes: - Add mkdir's to the custom target definitions to handle building outside of the source tree. The custom targets should potentially be replaced at some point with use of the app template's PROJECT_TARGET macros, but that's more involved than is warranted at the moment. - Fix CMAKE_BUILD_TYPE -> BUILD_TYPE in config.cmake to match the app template logic, and fix debug widget packaging. Bug-AGL: SPEC-3300 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I01b7c7b116b97a5f6b6330c767b5a6bdba9cdbce
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9bc11c5..b732286 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,6 +21,7 @@ CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)
add_custom_command(OUTPUT ${PROJECT_PKG_BUILD_DIR}/runxdg.toml
+ COMMAND mkdir -p ${PROJECT_PKG_BUILD_DIR}
COMMAND cp ${CMAKE_CURRENT_SOURCE_DIR}/runxdg.toml ${PROJECT_PKG_BUILD_DIR}/runxdg.toml
)
@@ -28,6 +29,7 @@ add_custom_target(runxdg_toml DEPENDS ${PROJECT_PKG_BUILD_DIR}/runxdg.toml)
add_dependencies(widget runxdg_toml)
add_custom_command(OUTPUT ${PACKAGE_BINDIR}/runxdg
+ COMMAND mkdir -p ${PACKAGE_BINDIR}
COMMAND cp ${CMAKE_CURRENT_SOURCE_DIR}/runxdg.sh ${PACKAGE_BINDIR}/runxdg
COMMAND chmod +x ${PACKAGE_BINDIR}/runxdg
)