aboutsummaryrefslogtreecommitdiffstats
path: root/sample/tachometer_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'sample/tachometer_git.bb')
-rw-r--r--sample/tachometer_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/sample/tachometer_git.bb b/sample/tachometer_git.bb
new file mode 100644
index 0000000..dca817e
--- /dev/null
+++ b/sample/tachometer_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Demo app for streeting-wheel"
+DESCRIPTION = "AGL demo app for streeting-wheel"
+HOMEPAGE = "http://oss-project.tmc-tokai.jp/gitlab/ces2019/tachometer"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+USERNAME = ""
+PASSWORD = ""
+
+SRC_URI = "git://oss-project.tmc-tokai.jp/gitlab/ces2019/tachometer.git;protocol=http;branch=master;user=${USERNAME}:${PASSWORD}"
+SRCREV = "671a58c7bb135bf6f8078d755efb76360d0d3c99"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "qtquickcontrols2 opencv"
+
+# runtime dependencies
+RDEPENDS_${PN} += "agl-service-steering-wheel"
+
+inherit qmake5 aglwgt