aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2022-09-29 14:22:11 +0300
committerMarius Vlad <marius.vlad@collabora.com>2022-09-29 19:44:20 +0300
commitbf125b0779f07e9d65f83da99d16accdad72b08b (patch)
tree8c13fc7de204e9a463c3dffa7033f021a2139df2 /meson.build
parent52c767388614e2ec6fa26851840bf01d97c5d49e (diff)
homescreen: Change from qmake to meson
This change will basically make way for adding grpc/protobuf support into homescreen, which turns out it's a pain to do with either qmake or cmake. Eventually, we'll move all our demos to using meson, which have gained a lot of support for building and support different technologies to allow far more saner configurations to take place. Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: Id64bf3d5b41912d32df7f78e94ab04d231bb0c83
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build33
1 files changed, 33 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..3d77b36
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,33 @@
+#
+# Copyright ©, 2022 Collabora, Ltd.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+project (
+ 'homescreen',
+ ['c', 'cpp'],
+ version : '1.0.0',
+ license : 'Apache-2.0',
+ meson_version : '>= 0.60.0',
+ default_options :
+ [
+ 'warning_level=1',
+ 'buildtype=debugoptimized',
+ 'c_std=c17',
+ 'cpp_std=c++17'
+ ],
+)
+
+qt5 = import('qt5')
+subdir('homescreen')