aboutsummaryrefslogtreecommitdiffstats
path: root/app/CMakeLists.txt
diff options
context:
space:
mode:
authorLoïc Collignon <loic.collignon@iot.bzh>2018-12-18 17:16:35 +0100
committerLoïc Collignon [ IoT.bzh ] <loic.collignon@iot.bzh>2018-12-19 10:06:56 +0000
commitd32d36b936cb031ba1b11c67c0d9c6afbdc280b3 (patch)
treea5a09e31bb41ced3ddea5dddf92530d187da4341 /app/CMakeLists.txt
parentf8da591c53f17df877e354896dbbf18410c53b6c (diff)
Reworked the way qml create sliders
Use the qml MVC to populate a ListView with components based on a template VolumeSlider. Should now handle potential disconnections, volume changes by third-party and also fix the issue where sliders are set to 0 at startup. Change-Id: I2961d5a1584a121c473ece253faa90a747c64445 Signed-off-by: Loïc Collignon <loic.collignon@iot.bzh>
Diffstat (limited to 'app/CMakeLists.txt')
-rw-r--r--app/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
index d23c33a..0259a79 100644
--- a/app/CMakeLists.txt
+++ b/app/CMakeLists.txt
@@ -35,7 +35,8 @@ endif()
add_executable(mixer
"main.cpp"
"mixer.cpp"
- "Mixer.qrc"
+ "audiorole.cpp"
+ "Mixer.qrc"
)
set_target_properties(mixer PROPERTIES