summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2024-09-27 01:31:31 +0900
committerNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2024-09-29 00:18:05 +0900
commit88fb60ad9d0c673f868d907ca451462ec16c9d7f (patch)
tree1c3df54cd7b518868ce2f7913ae81900e7498d6c /CMakeLists.txt
parent6a0b126643d36ff28d0fb9638498ca56ff3d43e7 (diff)
Rework momiscreen to migrate to Qt6
AGL momi IVI used weston with wayland-ivi-extention. At the scarthgap, it has issue for the touch event handling. New momiscreen changes role from homescreen bar to homescreen that is including compositor. Bug-AGL: SPEC-5162 Change-Id: I9cc92c508de2b49840690af1477fd52a37de7a86 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt51
1 files changed, 51 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..b8b4082
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,51 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.16)
+project(momiscreen LANGUAGES CXX)
+
+set(CMAKE_AUTOMOC ON)
+
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml)
+
+qt_add_executable(momiscreen
+ main.cpp
+)
+
+set_target_properties(momiscreen PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+
+target_link_libraries(momiscreen PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+)
+
+# Resources:
+set(momiscreen_resource_files
+ "main.qml"
+ "MomiBar.qml"
+ "DateBox.qml"
+ "images/12_Footer.png"
+ "images/14_Logo.png"
+ "images/15_Maps.png"
+ "images/16_Multimedia.png"
+ "images/17_Dashboard.png"
+ "images/18_Setting.png"
+ "images/19_Shadow.png"
+)
+
+qt6_add_resources(momiscreen "momiscreen"
+ PREFIX
+ "/"
+ FILES
+ ${momiscreen_resource_files}
+)
+
+install(TARGETS momiscreen
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ BUNDLE DESTINATION .
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+)