aboutsummaryrefslogtreecommitdiffstats
path: root/app/CMakeLists.txt
diff options
context:
space:
mode:
authorSam Thursfield <sam.thursfield@codethink.co.uk>2021-09-08 17:00:35 +0100
committerSam Thursfield <sam.thursfield@codethink.co.uk>2021-09-08 17:16:28 +0100
commitd4629afe76c0df5b14fe085e0a479e4b0e8f14cd (patch)
treee8a9ebfcfa7fb076859fa3ad1ae2ab5ed5d2bf3f /app/CMakeLists.txt
parentfa3bd315abd8a710d7493e6ffb7b54c521632202 (diff)
WIP: Add flatpak-builder+CMake build systemsandbox/samthursfield/flatpak
The existing QMake build relies on `wgtpkg` from app-fw. As QMake is becoming obsolete[1], I implemented a separate build system in CMake. This branch is WIP as it modifies the config search directory to /app/etc directly, which would break the native app build. 1. https://www.qt.io/blog/2019/08/07/technical-vision-qt-6 Signed-off-by: Sam Thursfield <sam.thursfield@codethink.co.uk> Change-Id: I89bfba04265cfad2b0d641e8c1060e62a5e275fd
Diffstat (limited to 'app/CMakeLists.txt')
-rw-r--r--app/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
new file mode 100644
index 0000000..61fc721
--- /dev/null
+++ b/app/CMakeLists.txt
@@ -0,0 +1,20 @@
+qt5_add_resources(RESOURCES navigation.qrc images/images.qrc)
+
+set(
+ SOURCES file_operation.cpp file_operation.h guidance_module.h main.cpp
+ markermodel.h
+)
+
+add_executable(navigation ${SOURCES} ${RESOURCES})
+
+target_compile_options(navigation
+ PUBLIC ${QTAPPFW_NAVIGATION_COMPILE_OPTIONS}
+)
+target_include_directories(navigation
+ PUBLIC ${QTAPPFW_NAVIGATION_INCLUDE_DIRS}
+)
+target_link_libraries(navigation
+ ${QTAPPFW_NAVIGATION_LIBRARIES} Qt5::Core Qt5::Qml Qt5::Quick Qt5::Location Qt5::Widgets
+)
+
+install(TARGETS navigation DESTINATION bin)