aboutsummaryrefslogtreecommitdiffstats
path: root/package/CMakeLists.txt
diff options
context:
space:
mode:
authorSam Thursfield <sam.thursfield@codethink.co.uk>2021-09-08 17:00:35 +0100
committerSam Thursfield <sam.thursfield@codethink.co.uk>2021-09-08 17:16:28 +0100
commitd4629afe76c0df5b14fe085e0a479e4b0e8f14cd (patch)
treee8a9ebfcfa7fb076859fa3ad1ae2ab5ed5d2bf3f /package/CMakeLists.txt
parentfa3bd315abd8a710d7493e6ffb7b54c521632202 (diff)
WIP: Add flatpak-builder+CMake build systemsandbox/samthursfield/flatpak
The existing QMake build relies on `wgtpkg` from app-fw. As QMake is becoming obsolete[1], I implemented a separate build system in CMake. This branch is WIP as it modifies the config search directory to /app/etc directly, which would break the native app build. 1. https://www.qt.io/blog/2019/08/07/technical-vision-qt-6 Signed-off-by: Sam Thursfield <sam.thursfield@codethink.co.uk> Change-Id: I89bfba04265cfad2b0d641e8c1060e62a5e275fd
Diffstat (limited to 'package/CMakeLists.txt')
-rw-r--r--package/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/CMakeLists.txt b/package/CMakeLists.txt
new file mode 100644
index 0000000..9b2b69e
--- /dev/null
+++ b/package/CMakeLists.txt
@@ -0,0 +1,4 @@
+install(
+ FILES flite jtalk
+ DESTINATION bin
+)