aboutsummaryrefslogtreecommitdiffstats
path: root/app/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'app/CMakeLists.txt')
-rw-r--r--app/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
new file mode 100644
index 0000000..61fc721
--- /dev/null
+++ b/app/CMakeLists.txt
@@ -0,0 +1,20 @@
+qt5_add_resources(RESOURCES navigation.qrc images/images.qrc)
+
+set(
+ SOURCES file_operation.cpp file_operation.h guidance_module.h main.cpp
+ markermodel.h
+)
+
+add_executable(navigation ${SOURCES} ${RESOURCES})
+
+target_compile_options(navigation
+ PUBLIC ${QTAPPFW_NAVIGATION_COMPILE_OPTIONS}
+)
+target_include_directories(navigation
+ PUBLIC ${QTAPPFW_NAVIGATION_INCLUDE_DIRS}
+)
+target_link_libraries(navigation
+ ${QTAPPFW_NAVIGATION_LIBRARIES} Qt5::Core Qt5::Qml Qt5::Quick Qt5::Location Qt5::Widgets
+)
+
+install(TARGETS navigation DESTINATION bin)