aboutsummaryrefslogtreecommitdiffstats
path: root/app/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'app/meson.build')
-rw-r--r--app/meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/app/meson.build b/app/meson.build
index a7d1e41..b2ee673 100644
--- a/app/meson.build
+++ b/app/meson.build
@@ -1,5 +1,5 @@
cpp = meson.get_compiler('cpp')
-qt5_dep = dependency('qt5', modules: ['Qml', 'Quick', 'Gui', 'Location'])
+qt_dep = dependency('qt6', modules: ['Qml', 'Quick', 'Gui', 'Location'])
grpcpp_reflection_dep = cpp.find_library('grpc++_reflection')
protoc = find_program('protoc')
@@ -34,7 +34,7 @@ dep_qtappfw = [
]
tbtnavi_dep = [
- qt5_dep,
+ qt_dep,
dep_qtappfw,
grpc_deps
]
@@ -46,15 +46,15 @@ tbtnavi_headers = [
'AglShellGrpcClient.h'
]
-moc_files = qt5.compile_moc(headers: tbtnavi_headers,
- dependencies: qt5_dep)
+moc_files = qt6.compile_moc(headers: tbtnavi_headers,
+ dependencies: qt_dep)
tbtnavi_resources = [
'images/images.qrc',
'qml/qml.qrc'
]
-resource_files = qt5.compile_resources(sources: tbtnavi_resources)
+resource_files = qt6.compile_resources(sources: tbtnavi_resources)
tbtnavi_src = [
'main.cpp',