summaryrefslogtreecommitdiffstats
path: root/AlsaSound/HALayer/IntelHda/CMakeLists.txt
diff options
context:
space:
mode:
authorfulup <fulup.arfoll@iot.bzh>2017-04-09 14:35:00 +0200
committerfulup <fulup.arfoll@iot.bzh>2017-04-09 14:35:00 +0200
commit6e70aac6c9f02496978d3d02efb355d66fb36ceb (patch)
treed50df20591076b3da2031b2b9eb249f2a1921f53 /AlsaSound/HALayer/IntelHda/CMakeLists.txt
parentc75c329e08f4c189419aa4c5607f38890885b46c (diff)
Clean CMAKE structure and rename files/directories
Diffstat (limited to 'AlsaSound/HALayer/IntelHda/CMakeLists.txt')
-rw-r--r--AlsaSound/HALayer/IntelHda/CMakeLists.txt36
1 files changed, 0 insertions, 36 deletions
diff --git a/AlsaSound/HALayer/IntelHda/CMakeLists.txt b/AlsaSound/HALayer/IntelHda/CMakeLists.txt
deleted file mode 100644
index 89665e4..0000000
--- a/AlsaSound/HALayer/IntelHda/CMakeLists.txt
+++ /dev/null
@@ -1,36 +0,0 @@
-###########################################################################
-# Copyright 2015, 2016, 2017 IoT.bzh
-#
-# author: Fulup Ar Foll <fulup@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-
-INCLUDE_DIRECTORIES(${include_dirs})
-
-##################################################
-# Inte-HDA sound card Hardware Abstraction Layer
-##################################################
-ADD_LIBRARY(intel-hda-hal MODULE IntelHdaHAL.c )
-
-SET_TARGET_PROPERTIES(intel-hda-hal PROPERTIES
- PREFIX ""
- LINK_FLAGS "-Wl,--version-script=${CMAKE_SOURCE_DIR}/export.map"
-)
-
-TARGET_LINK_LIBRARIES(intel-hda-hal ${link_libraries})
-INSTALL(TARGETS intel-hda-hal
- LIBRARY DESTINATION ${binding_install_dir})
-
-