summaryrefslogtreecommitdiffstats
path: root/hook-plugin/CMakeLists.txt
diff options
context:
space:
mode:
authorFulup Ar Foll <fulup@iot.bzh>2017-10-27 17:44:20 +0200
committerFulup Ar Foll <fulup@iot.bzh>2017-10-27 17:44:20 +0200
commit57710ab4388dd386a8c60b6b007603f6e3fdd1d2 (patch)
tree21ad0ba898c9d8683c8814286c391d4c7e623133 /hook-plugin/CMakeLists.txt
parentf9774538ec99c812b7effc3b77160608a343fce0 (diff)
Reinstall tcp/ws plugin until Jose fix unix/ws socket version
Diffstat (limited to 'hook-plugin/CMakeLists.txt')
-rw-r--r--hook-plugin/CMakeLists.txt21
1 files changed, 19 insertions, 2 deletions
diff --git a/hook-plugin/CMakeLists.txt b/hook-plugin/CMakeLists.txt
index 329b2ef..197fb4c 100644
--- a/hook-plugin/CMakeLists.txt
+++ b/hook-plugin/CMakeLists.txt
@@ -19,10 +19,27 @@
# Activate ALSA dynamic build build mode get resolve "snd_dlsym_start"
add_compile_options(-DPIC)
-PROJECT_TARGET_ADD(policy_hook_cb)
+PROJECT_TARGET_ADD(policy_hook_tcp)
# Define targets
- ADD_LIBRARY(${TARGET_NAME} MODULE PolicyHookCb.c)
+ ADD_LIBRARY(${TARGET_NAME} MODULE PolicyHookTcp.c)
+
+ # Alsa Plugin properties
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ PREFIX ""
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ ${link_libraries}
+ )
+ install(TARGETS ${TARGET_NAME} LIBRARY DESTINATION lib)
+
+PROJECT_TARGET_ADD(policy_hook_unix)
+
+ # Define targets
+ ADD_LIBRARY(${TARGET_NAME} MODULE PolicyHookUnix.c)
# Alsa Plugin properties
SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES