summaryrefslogtreecommitdiffstats
path: root/hook-plugin/CMakeLists.txt
diff options
context:
space:
mode:
authorFulup Ar Foll <fulup@iot.bzh>2017-11-01 19:22:36 +0100
committerFulup Ar Foll <fulup@iot.bzh>2017-11-01 19:22:36 +0100
commitfb2566c629de780c8ddc88058c864ea08436d1de (patch)
tree7cba08126f8fd0a11102bbd506eaf70a67022b1f /hook-plugin/CMakeLists.txt
parentbc799a90ab7cc23dbe7286eb38d64af545de417c (diff)
Move to support Audio-4a High Level API
Diffstat (limited to 'hook-plugin/CMakeLists.txt')
-rw-r--r--hook-plugin/CMakeLists.txt54
1 files changed, 0 insertions, 54 deletions
diff --git a/hook-plugin/CMakeLists.txt b/hook-plugin/CMakeLists.txt
deleted file mode 100644
index 197fb4c..0000000
--- a/hook-plugin/CMakeLists.txt
+++ /dev/null
@@ -1,54 +0,0 @@
-###########################################################################
-# Copyright 2015, 2016, 2017 IoT.bzh
-#
-# author: Fulup Ar Foll <fulup@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-# Activate ALSA dynamic build build mode get resolve "snd_dlsym_start"
-add_compile_options(-DPIC)
-
-PROJECT_TARGET_ADD(policy_hook_tcp)
-
- # Define targets
- ADD_LIBRARY(${TARGET_NAME} MODULE PolicyHookTcp.c)
-
- # Alsa Plugin properties
- SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- PREFIX ""
- OUTPUT_NAME ${TARGET_NAME}
- )
-
- # Library dependencies (include updates automatically)
- TARGET_LINK_LIBRARIES(${TARGET_NAME}
- ${link_libraries}
- )
- install(TARGETS ${TARGET_NAME} LIBRARY DESTINATION lib)
-
-PROJECT_TARGET_ADD(policy_hook_unix)
-
- # Define targets
- ADD_LIBRARY(${TARGET_NAME} MODULE PolicyHookUnix.c)
-
- # Alsa Plugin properties
- SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- PREFIX ""
- OUTPUT_NAME ${TARGET_NAME}
- )
-
- # Library dependencies (include updates automatically)
- TARGET_LINK_LIBRARIES(${TARGET_NAME}
- ${link_libraries}
- )
- install(TARGETS ${TARGET_NAME} LIBRARY DESTINATION lib)