summaryrefslogtreecommitdiffstats
path: root/HDA-intel/CMakeLists.txt
diff options
context:
space:
mode:
authorFulup Ar Foll <fulup@iot.bzh>2017-10-24 22:12:48 +0200
committerFulup Ar Foll <fulup@iot.bzh>2017-10-24 22:12:48 +0200
commit6561612a64a52d93260444066a266adb06ac71ad (patch)
tree310cc6cd3fd65e5ed6d02f7743ae2def4ac80644 /HDA-intel/CMakeLists.txt
parent2fd0fa8c77dbaaf40ba0812e43b6637ff1d1d76e (diff)
Initial working version as independent repo
Diffstat (limited to 'HDA-intel/CMakeLists.txt')
-rw-r--r--HDA-intel/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/HDA-intel/CMakeLists.txt b/HDA-intel/CMakeLists.txt
new file mode 100644
index 0000000..956a0f6
--- /dev/null
+++ b/HDA-intel/CMakeLists.txt
@@ -0,0 +1,39 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(hal-intel-hda)
+
+ # Define project Targets
+ ADD_LIBRARY(${TARGET_NAME} MODULE IntelHdaHAL.c)
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ PREFIX "afb-"
+ LABELS "BINDING"
+ LINK_FLAGS ${BINDINGS_LINK_FLAG}
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ hal-utilities
+ ${link_libraries}
+ )
+