aboutsummaryrefslogtreecommitdiffstats
path: root/USB-Device/CMakeLists.txt
diff options
context:
space:
mode:
authorTai Vuong <tvuong@audiokinetic.com>2017-11-03 18:41:58 -0400
committerTai Vuong <tvuong@audiokinetic.com>2017-11-03 18:41:58 -0400
commit67a688068d6a474650d15b63d93e54edc690e237 (patch)
tree804c59c8e53c0747056f9048bce5477cc02d6863 /USB-Device/CMakeLists.txt
parent86cfccd0951f7c82f409eb763bc991042055c134 (diff)
add ensoniq, usb hal and match volume and ramp name with HLB audio role
Diffstat (limited to 'USB-Device/CMakeLists.txt')
-rw-r--r--USB-Device/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/USB-Device/CMakeLists.txt b/USB-Device/CMakeLists.txt
new file mode 100644
index 0000000..7150514
--- /dev/null
+++ b/USB-Device/CMakeLists.txt
@@ -0,0 +1,39 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(hal-usb-device)
+
+ # Define project Targets
+ ADD_LIBRARY(${TARGET_NAME} MODULE UsbDeviceHAL.c)
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ PREFIX "afb-"
+ LABELS "BINDING"
+ LINK_FLAGS ${BINDINGS_LINK_FLAG}
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ hal-utilities-4a
+ ${link_libraries}
+ )
+