summaryrefslogtreecommitdiffstats
path: root/4a-hal-utilities/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Aillet <jonathan.aillet@iot.bzh>2019-01-07 11:30:12 +0100
committerJonathan Aillet <jonathan.aillet@iot.bzh>2019-01-28 15:38:28 +0100
commit4f44ee8f17789ac27cd1e29a451ac450c7dbeb06 (patch)
treee27e4c05a417ef2d8a9ca12451af0f8e298cc1cb /4a-hal-utilities/CMakeLists.txt
parenta93c3566d181e82a39b32acffdb13a411ca4f5f5 (diff)
Turn '4a-hal-utilities' into an internal library
That way, includes will be cleaner and '4a-hal-utilities' functions will be usable in plugin. Change-Id: I8a2146bd4e5dd5ef449b9ba7f2b1eed4d59045d3 Signed-off-by: Jonathan Aillet <jonathan.aillet@iot.bzh>
Diffstat (limited to '4a-hal-utilities/CMakeLists.txt')
-rw-r--r--4a-hal-utilities/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/4a-hal-utilities/CMakeLists.txt b/4a-hal-utilities/CMakeLists.txt
new file mode 100644
index 0000000..a45cb2c
--- /dev/null
+++ b/4a-hal-utilities/CMakeLists.txt
@@ -0,0 +1,40 @@
+###########################################################################
+# Copyright 2015, 2016, 2017, 2018, 2019 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+# contrib: Jonathan Aillet <jonathan.aillet@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(4a-hal-utilities)
+
+ # Define project Targets
+ ADD_LIBRARY(${TARGET_NAME} STATIC
+ 4a-hal-utilities-alsa-data.c
+ 4a-hal-utilities-appfw-responses-handler.c
+ 4a-hal-utilities-data.c
+ 4a-hal-utilities-verbs-loader.c)
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ afb-helpers
+ ctl-utilities
+ ${link_libraries}
+ )
+
+ # Define target includes for this target client
+ TARGET_INCLUDE_DIRECTORIES(${TARGET_NAME} PUBLIC
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ )