aboutsummaryrefslogtreecommitdiffstats
path: root/4a-hal/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Aillet <jonathan.aillet@iot.bzh>2018-06-03 19:16:32 +0200
committerJonathan Aillet <jonathan.aillet@iot.bzh>2018-10-08 15:51:00 +0200
commit67fc2c25d727888cb45a847971771f34674b68ff (patch)
tree4fab47f096de6a897f8f33028ad8072d7bd07815 /4a-hal/CMakeLists.txt
parent70108117e5f392eff2710d5d6a0cd04e400e4cde (diff)
Handle hal status using card presence and mixer init
Test audio card presence at hal startup using alsacore call. Handling a new state of hal. Move alsacore link files into 4a-hal-controllers. Check state of hal before mixer initialization call. Actualize hal state if mixer initlialization ends well. Add a sndCardId filed to 'SpecificHalData' structure which will contain audio card if (from alsa). Change-Id: I2e82a14ee6ba6e63f06fe2b498587783941b7b98 Signed-off-by: Jonathan Aillet <jonathan.aillet@iot.bzh>
Diffstat (limited to '4a-hal/CMakeLists.txt')
-rw-r--r--4a-hal/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/4a-hal/CMakeLists.txt b/4a-hal/CMakeLists.txt
index e205ec4..cf485fd 100644
--- a/4a-hal/CMakeLists.txt
+++ b/4a-hal/CMakeLists.txt
@@ -24,12 +24,12 @@ PROJECT_TARGET_ADD(4a-hal)
# Define project Targets
add_library(${TARGET_NAME} MODULE
${TARGET_NAME}-utilities/${TARGET_NAME}-utilities-appfw-responses-handler.c
- ${TARGET_NAME}-utilities/${TARGET_NAME}-utilities-alsa-link.c
${TARGET_NAME}-utilities/${TARGET_NAME}-utilities-data.c
${TARGET_NAME}-utilities/${TARGET_NAME}-utilities-verbs-loader.c
${TARGET_NAME}-manager/${TARGET_NAME}-manager.c
${TARGET_NAME}-manager/${TARGET_NAME}-manager-cb.c
${TARGET_NAME}-manager/${TARGET_NAME}-manager-events.c
+ ${TARGET_NAME}-controllers/${TARGET_NAME}-controllers-alsacore-link.c
${TARGET_NAME}-controllers/${TARGET_NAME}-controllers-api-loader.c
${TARGET_NAME}-controllers/${TARGET_NAME}-controllers-cb.c
${TARGET_NAME}-controllers/${TARGET_NAME}-controllers-mixer-handler.c