aboutsummaryrefslogtreecommitdiffstats
path: root/4a-hal/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Aillet <jonathan.aillet@iot.bzh>2018-06-01 22:44:21 +0200
committerJonathan Aillet <jonathan.aillet@iot.bzh>2018-10-08 15:51:00 +0200
commit8943be0ab8f315d935c9bfe7b46523c4e94b0025 (patch)
treef6043225194b93380a6e253822186fe088c3a3cd /4a-hal/CMakeLists.txt
parent67c4b9bb390192fa1cb4004da0ca3ec4ad8d54a6 (diff)
Handle mixer response after its init
Handle mixer response to get created streams and them corresponding card ids after mixer initialization. Store these informations into the controller hal data strucure. Creation of a verb for each stream is now handle at response handling. Remove unnecessary function because we don't need to search for a stream by his name. Change-Id: Id9e598668b071ca18d152b57e71109314025f698 Signed-off-by: Jonathan Aillet <jonathan.aillet@iot.bzh>
Diffstat (limited to '4a-hal/CMakeLists.txt')
-rw-r--r--4a-hal/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/4a-hal/CMakeLists.txt b/4a-hal/CMakeLists.txt
index b963bc0..323c490 100644
--- a/4a-hal/CMakeLists.txt
+++ b/4a-hal/CMakeLists.txt
@@ -31,6 +31,7 @@ PROJECT_TARGET_ADD(4a-hal)
${TARGET_NAME}-manager/${TARGET_NAME}-manager-events.c
${TARGET_NAME}-controllers/${TARGET_NAME}-controllers-api-loader.c
${TARGET_NAME}-controllers/${TARGET_NAME}-controllers-cb.c
+ ${TARGET_NAME}-controllers/${TARGET_NAME}-controllers-mixer-handler.c
)
# Binder exposes a unique public entry point