aboutsummaryrefslogtreecommitdiffstats
path: root/4a-hal/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Aillet <jonathan.aillet@iot.bzh>2018-05-23 21:14:08 +0200
committerJonathan Aillet <jonathan.aillet@iot.bzh>2018-10-08 15:51:00 +0200
commite21766d185885a985ddf5b2f312171b3f81eb94e (patch)
tree213927a632f136680516ebd6bd81a43b7ae859d3 /4a-hal/CMakeLists.txt
parentd43607bd8665d5710e5258cf237c1f79ec94b7d9 (diff)
Add a 'List' verb to each hal controller api
Add a 'List' verb to each hal controller api which will list verbs available for this api. The callback of the verb is not implemented yet. Change-Id: Ibc44ef8673267b0b952b32fb256214452aa3c000 Signed-off-by: Jonathan Aillet <jonathan.aillet@iot.bzh>
Diffstat (limited to '4a-hal/CMakeLists.txt')
-rw-r--r--4a-hal/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/4a-hal/CMakeLists.txt b/4a-hal/CMakeLists.txt
index d7d536b..b963bc0 100644
--- a/4a-hal/CMakeLists.txt
+++ b/4a-hal/CMakeLists.txt
@@ -30,6 +30,7 @@ PROJECT_TARGET_ADD(4a-hal)
${TARGET_NAME}-manager/${TARGET_NAME}-manager-cb.c
${TARGET_NAME}-manager/${TARGET_NAME}-manager-events.c
${TARGET_NAME}-controllers/${TARGET_NAME}-controllers-api-loader.c
+ ${TARGET_NAME}-controllers/${TARGET_NAME}-controllers-cb.c
)
# Binder exposes a unique public entry point