summaryrefslogtreecommitdiffstats
path: root/4a-hal/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Aillet <jonathan.aillet@iot.bzh>2019-04-18 12:40:25 +0200
committerJonathan Aillet <jonathan.aillet@iot.bzh>2019-05-24 12:05:52 +0200
commit68138a3ec7a78ad7304d291ff92d8e5292847c4e (patch)
tree9157134d50a749c838afdf93a49c4ce17a018347 /4a-hal/CMakeLists.txt
parent196e723e79a1f5eae41cf4a8b1450df0679a4af8 (diff)
Clarify internals hal functions and files names
The purpose of this commit is to have of a more standard way to name files and functions used to generate/handle hal api (generated from hal json configuration file). It occurred to me that 'hal-controller' was not a good name because it is harder for people who don't know about the app-controller to understanded what is the purpose of these files/functions. It was renamed to 'internal-hal' because it's about hal that are all handle/load by hal-manager in opposition of external-hal that are independant binding/binder that can register themselves to hal-manager. BUG-AGL: SPEC-2329 Change-Id: I11b7efe64ec474b004a2a15ed8969b9db95d428f Signed-off-by: Jonathan Aillet <jonathan.aillet@iot.bzh>
Diffstat (limited to '4a-hal/CMakeLists.txt')
-rw-r--r--4a-hal/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/4a-hal/CMakeLists.txt b/4a-hal/CMakeLists.txt
index 0c722c5..b863c5f 100644
--- a/4a-hal/CMakeLists.txt
+++ b/4a-hal/CMakeLists.txt
@@ -23,13 +23,13 @@ PROJECT_TARGET_ADD(4a-hal)
# Define project Targets
add_library(${TARGET_NAME} MODULE
- ${TARGET_NAME}-manager/${TARGET_NAME}-manager.c
- ${TARGET_NAME}-manager/${TARGET_NAME}-manager-cb.c
- ${TARGET_NAME}-controllers/${TARGET_NAME}-controllers-alsacore-link.c
- ${TARGET_NAME}-controllers/${TARGET_NAME}-controllers-api-loader.c
- ${TARGET_NAME}-controllers/${TARGET_NAME}-controllers-cb.c
- ${TARGET_NAME}-controllers/${TARGET_NAME}-controllers-mixer-link.c
- ${TARGET_NAME}-controllers/${TARGET_NAME}-controllers-value-handler.c
+ 4a-hal-manager/4a-hal-manager.c
+ 4a-hal-manager/4a-hal-manager-cb.c
+ 4a-internals-hal/4a-internals-hal-alsacore-link.c
+ 4a-internals-hal/4a-internals-hal-api-loader.c
+ 4a-internals-hal/4a-internals-hal-cb.c
+ 4a-internals-hal/4a-internals-hal-mixer-link.c
+ 4a-internals-hal/4a-internals-hal-value-handler.c
)
# Binder exposes a unique public entry point