summaryrefslogtreecommitdiffstats
path: root/plugins/lib/bluetooth/CMakeLists.txt
diff options
context:
space:
mode:
authorThierry Bultel <thierry.bultel@iot.bzh>2018-12-05 14:05:10 +0100
committerThierry Bultel <thierry.bultel@iot.bzh>2018-12-20 16:55:46 +0000
commit01d55ed8cdd01ca4a7b391ca61c80084bd5a6f2f (patch)
treed73ce778a2177e82e07e9d31891a827467fbadd4 /plugins/lib/bluetooth/CMakeLists.txt
parentdbe555be80dd10bb315b14bbebcb42f8b883e2c9 (diff)
Adds support for bluetooth audio through bluez-alsaguppy_6.99.4guppy_6.99.3guppy/6.99.4guppy/6.99.36.99.46.99.3
Implements a new bluealsa plugin to the HAL manager, reacting to the changes of the available transports. This plugin is linked with the new bluealsa.so shared library. New transports (SCO & A2DP) result in softmixer invocations of the "attach" verb, that creates the new capture (eg, A2DP capture from bluealsa ioplug PCM, SCO microphone capture), playbacks (SCO playback to a softmixer zone, and SCO output to bluealsa iogplug PCM). When a transport disappears, the hal manager calls the transaction deletion verb that will tell the softmixer to remove the created streams and associated objects. Change-Id: I36037a4f14ef7fee38070fc0df66c40b4ce46e8b Signed-off-by: Thierry Bultel <thierry.bultel@iot.bzh>
Diffstat (limited to 'plugins/lib/bluetooth/CMakeLists.txt')
-rw-r--r--plugins/lib/bluetooth/CMakeLists.txt47
1 files changed, 0 insertions, 47 deletions
diff --git a/plugins/lib/bluetooth/CMakeLists.txt b/plugins/lib/bluetooth/CMakeLists.txt
deleted file mode 100644
index ae9f5ab..0000000
--- a/plugins/lib/bluetooth/CMakeLists.txt
+++ /dev/null
@@ -1,47 +0,0 @@
-###########################################################################
-# Copyright 2015, 2016, 2017, 2018 IoT.bzh
-#
-# author: Jonathan Aillet <jonathan.aillet@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-PROJECT_TARGET_ADD(hal-bt)
-
- # Define targets
- ADD_LIBRARY(${TARGET_NAME} MODULE
- hal-bt.c
- hal-bt-cb.c
- hal-bt-data.c
- hal-bt-mixer-link.c
- )
-
- # Alsa Plugin properties
- SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- LABELS "PLUGIN"
- PREFIX ""
- SUFFIX ".ctlso"
- OUTPUT_NAME ${TARGET_NAME}
- )
-
- # Library dependencies (include updates automatically)
- TARGET_LINK_LIBRARIES(${TARGET_NAME}
- afb-helpers
- ctl-utilities
- ${link_libraries}
- )
-
- target_include_directories(${TARGET_NAME}
- PRIVATE "${CMAKE_SOURCE_DIR}/app-controller/ctl-lib"
- PRIVATE "${CMAKE_SOURCE_DIR}/4a-hal/4a-hal-utilities"
- )