summaryrefslogtreecommitdiffstats
path: root/4a-hal/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '4a-hal/CMakeLists.txt')
-rw-r--r--4a-hal/CMakeLists.txt51
1 files changed, 0 insertions, 51 deletions
diff --git a/4a-hal/CMakeLists.txt b/4a-hal/CMakeLists.txt
deleted file mode 100644
index b863c5f..0000000
--- a/4a-hal/CMakeLists.txt
+++ /dev/null
@@ -1,51 +0,0 @@
-###########################################################################
-# Copyright 2015, 2016, 2017, 2018 IoT.bzh
-#
-# author: Fulup Ar Foll <fulup@iot.bzh>
-# contrib: Romain Forlot <romain.forlot@iot.bzh>
-# conrtib: Jonathan Aillet <jonathan.aillet@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-# Add target to project dependency list
-PROJECT_TARGET_ADD(4a-hal)
-
- # Define project Targets
- add_library(${TARGET_NAME} MODULE
- 4a-hal-manager/4a-hal-manager.c
- 4a-hal-manager/4a-hal-manager-cb.c
- 4a-internals-hal/4a-internals-hal-alsacore-link.c
- 4a-internals-hal/4a-internals-hal-api-loader.c
- 4a-internals-hal/4a-internals-hal-cb.c
- 4a-internals-hal/4a-internals-hal-mixer-link.c
- 4a-internals-hal/4a-internals-hal-value-handler.c
- )
-
- # Binder exposes a unique public entry point
- SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- PREFIX ""
- LABELS "BINDING" # Need to be in V3
- LINK_FLAGS ${BINDINGS_LINK_FLAG}
- OUTPUT_NAME ${TARGET_NAME}
- )
-
- # Library dependencies (include updates automatically)
- TARGET_LINK_LIBRARIES(${TARGET_NAME}
- 4a-hal-utilities
- )
-
- # Define target includes for this target client
- TARGET_INCLUDE_DIRECTORIES(${TARGET_NAME}
- PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}
- )