summaryrefslogtreecommitdiffstats
path: root/HDA-intel/CMakeLists.txt
diff options
context:
space:
mode:
authorDominig ar Foll Intel Open Source <dominig.arfoll@fridu.net>2017-12-13 10:43:35 +0100
committerDominig ar Foll Intel Open Source <dominig.arfoll@fridu.net>2017-12-13 10:44:37 +0100
commita8e946de822d1611549bbdbcfc04ca4f5e14773a (patch)
treec05a5f4339cce019dc8659cb114a28c2847fe37e /HDA-intel/CMakeLists.txt
parenta4495f6929ac3c516e42d5a272d86a750be4b146 (diff)
HAL(s) need to match the exact HW palform alsa controls which are different even for similar platforms #SPEC-1184
Change-Id: Id962ea5365af7539277f335b83169712291aa3df Signed-off-by: Dominig ar Foll Intel Open Source <dominig.arfoll@fridu.net>
Diffstat (limited to 'HDA-intel/CMakeLists.txt')
-rw-r--r--HDA-intel/CMakeLists.txt39
1 files changed, 0 insertions, 39 deletions
diff --git a/HDA-intel/CMakeLists.txt b/HDA-intel/CMakeLists.txt
deleted file mode 100644
index 68314b4..0000000
--- a/HDA-intel/CMakeLists.txt
+++ /dev/null
@@ -1,39 +0,0 @@
-###########################################################################
-# Copyright 2015, 2016, 2017 IoT.bzh
-#
-# author: Fulup Ar Foll <fulup@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-if(HAL_INTEL_HDA)
- # Add target to project dependency list
- PROJECT_TARGET_ADD(hal-intel-hda)
-
- # Define project Targets
- ADD_LIBRARY(${TARGET_NAME} MODULE IntelHdaHAL.c)
-
- # Binder exposes a unique public entry point
- SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- PREFIX "afb-"
- LABELS "BINDING"
- LINK_FLAGS ${BINDINGS_LINK_FLAG}
- OUTPUT_NAME ${TARGET_NAME}
- )
-
- # Library dependencies (include updates automatically)
- TARGET_LINK_LIBRARIES(${TARGET_NAME}
- hal-utilities-4a
- ${link_libraries}
- )
-endif()