summaryrefslogtreecommitdiffstats
path: root/ALSA-afb/CMakeLists.txt
diff options
context:
space:
mode:
authorfulup <fulup.arfoll@iot.bzh>2017-08-10 17:37:24 +0200
committerfulup <fulup.arfoll@iot.bzh>2017-08-10 17:37:24 +0200
commiteb6a78be524aaee70fca55b86a7b065763591178 (patch)
tree9db4e1e9f75ef18b90255a468ab5087e65bba5c3 /ALSA-afb/CMakeLists.txt
parent302d4bfcc49c69ea8251e1755ba3876555f680aa (diff)
Work in Progress
Diffstat (limited to 'ALSA-afb/CMakeLists.txt')
-rw-r--r--ALSA-afb/CMakeLists.txt41
1 files changed, 0 insertions, 41 deletions
diff --git a/ALSA-afb/CMakeLists.txt b/ALSA-afb/CMakeLists.txt
deleted file mode 100644
index 876e837..0000000
--- a/ALSA-afb/CMakeLists.txt
+++ /dev/null
@@ -1,41 +0,0 @@
-###########################################################################
-# Copyright 2015, 2016, 2017 IoT.bzh
-#
-# author: Fulup Ar Foll <fulup@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-# Add target to project dependency list
-PROJECT_TARGET_ADD(alsa-lowlevel)
-
- # Define project Targets
- ADD_LIBRARY(${TARGET_NAME} MODULE Alsa-ApiHat.c Alsa-SetGet.c Alsa-Ucm.c Alsa-AddCtl.c Alsa-RegEvt.c)
-
- # Binder exposes a unique public entry point
- SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- PREFIX "afb-"
- LABELS "BINDING"
- LINK_FLAGS ${BINDINGS_LINK_FLAG}
- OUTPUT_NAME ${TARGET_NAME}
- )
-
- # Library dependencies (include updates automatically)
- TARGET_LINK_LIBRARIES(${TARGET_NAME}
- audio-common
- ${link_libraries}
- )
-
- # installation directory
- INSTALL(TARGETS ${TARGET_NAME}
- LIBRARY DESTINATION ${BINDINGS_INSTALL_DIR})