aboutsummaryrefslogtreecommitdiffstats
path: root/Audio-Common/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-08-22 19:09:18 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2017-08-22 19:09:42 +0200
commit606ccd2405a55eab4c909160c951c083bccd825d (patch)
tree790d438e234fc31283f86c2ce8bf9e1cdc94e8f7 /Audio-Common/CMakeLists.txt
parent1d7c537cb1106f8daf36a6bbd69ecd377b542b39 (diff)
Remove Controller that is now stand alone.
Also move filescan and wrap-json library into a separate submodule afb-utilities Change-Id: Ic46cceb88cd25a808cbd0e5e6da53f56f9fc786c Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'Audio-Common/CMakeLists.txt')
-rw-r--r--Audio-Common/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/Audio-Common/CMakeLists.txt b/Audio-Common/CMakeLists.txt
index bd3f344..e50edd2 100644
--- a/Audio-Common/CMakeLists.txt
+++ b/Audio-Common/CMakeLists.txt
@@ -19,8 +19,8 @@
# Add target to project dependency list
PROJECT_TARGET_ADD(audio-common)
- # Define targets
- ADD_LIBRARY(${TARGET_NAME} STATIC audio-common.c wrap-json.c filescan-utils)
+ # Define targets
+ ADD_LIBRARY(${TARGET_NAME} STATIC audio-common.c)
# Library properties
SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
@@ -28,11 +28,11 @@ PROJECT_TARGET_ADD(audio-common)
)
# Library dependencies
- #TARGET_LINK_LIBRARIES(${TARGET_NAME}
- # empty
- #)
-
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ afb-utilities
+ )
+
# Define target includes
- TARGET_INCLUDE_DIRECTORIES(${TARGET_NAME}
+ TARGET_INCLUDE_DIRECTORIES(${TARGET_NAME}
PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}
-) \ No newline at end of file
+)