summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-08-18 10:45:11 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2017-08-18 10:45:11 +0200
commit3648e16e17a908e7f08bde789fefe3abc6981544 (patch)
tree46423715d06b9c166d3b07fed070fcf077114f8f /CMakeLists.txt
parent6fa8948541948946e3b3e4d93d064e15e33f8e97 (diff)
Latest app-templates features integration
- CMake >= 3.6 mandatory - Change DATA and HTDOCS targets methods to use macro add_input_files() - header generated from OpenAPI file using BINDINGV2 label and set_openapi_filename() macro. - Adjusted README to reflect new cmake requirement Change-Id: I8da515b98c1877d5be5e51f2bf94d691ac3cefb7 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index faef509..b8bb607 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,7 +15,7 @@
# See the License for the specific language governing permissions and
# limitations under the License.
###########################################################################
-CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
+CMAKE_MINIMUM_REQUIRED(VERSION 3.6)
# Do not change this file, config is located into conf.d
include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)