summaryrefslogtreecommitdiffstats
path: root/HAL-afb/CMakeLists.txt
diff options
context:
space:
mode:
authorfulup <fulup.arfoll@iot.bzh>2017-04-09 14:35:00 +0200
committerfulup <fulup.arfoll@iot.bzh>2017-04-09 14:35:00 +0200
commit6e70aac6c9f02496978d3d02efb355d66fb36ceb (patch)
treed50df20591076b3da2031b2b9eb249f2a1921f53 /HAL-afb/CMakeLists.txt
parentc75c329e08f4c189419aa4c5607f38890885b46c (diff)
Clean CMAKE structure and rename files/directories
Diffstat (limited to 'HAL-afb/CMakeLists.txt')
-rw-r--r--HAL-afb/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/HAL-afb/CMakeLists.txt b/HAL-afb/CMakeLists.txt
new file mode 100644
index 0000000..c36f530
--- /dev/null
+++ b/HAL-afb/CMakeLists.txt
@@ -0,0 +1,28 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+
+# Include any directory starting with a Capital letter
+# -----------------------------------------------------
+file(GLOB filelist "[A-Z]*")
+foreach(filename ${filelist})
+ if(EXISTS "${filename}/CMakeLists.txt")
+ add_subdirectory(${filename})
+ endif(EXISTS "${filename}/CMakeLists.txt")
+endforeach()
+