aboutsummaryrefslogtreecommitdiffstats
path: root/HAL-afb/HAL_MOST_UNICENS/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Jahnke <tjahnk@users.noreply.github.com>2017-08-11 09:28:55 +0200
committerTobias Jahnke <tjahnk@users.noreply.github.com>2017-08-16 16:00:50 +0200
commitabe141f1d4dd46fe2bda6cc56db0ceaa964d87b1 (patch)
treed4451649f41ce064c93c6190808a04d404d0b61c /HAL-afb/HAL_MOST_UNICENS/CMakeLists.txt
parent3d4ecfd96e63d4fbc719e4be06e022a6811b0c1e (diff)
project name HAL_MOST_UNICENS is now uppercase
Diffstat (limited to 'HAL-afb/HAL_MOST_UNICENS/CMakeLists.txt')
-rw-r--r--HAL-afb/HAL_MOST_UNICENS/CMakeLists.txt49
1 files changed, 49 insertions, 0 deletions
diff --git a/HAL-afb/HAL_MOST_UNICENS/CMakeLists.txt b/HAL-afb/HAL_MOST_UNICENS/CMakeLists.txt
new file mode 100644
index 0000000..e532191
--- /dev/null
+++ b/HAL-afb/HAL_MOST_UNICENS/CMakeLists.txt
@@ -0,0 +1,49 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+ADD_SUBDIRECTORY(ucs2-vol)
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(hal-most-unicens)
+
+ # Define project Targets
+ ADD_LIBRARY(hal-most-unicens MODULE hal_most_unicens.c wrap-json.c wrap_unicens.c wrap_volume.c)
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ PREFIX "afb-"
+ LABELS "BINDING"
+ LINK_FLAGS ${BINDINGS_LINK_FLAG}
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ hal-interface
+ audio-interface
+ ucs2-volume
+ )
+
+ # installation directory
+ INSTALL(TARGETS ${TARGET_NAME}
+ LIBRARY DESTINATION ${BINDINGS_INSTALL_DIR})
+
+ # Define properties to expose when others use this target
+ TARGET_INCLUDE_DIRECTORIES(${TARGET_NAME}
+ PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}/ucs2-vol/inc
+ )