aboutsummaryrefslogtreecommitdiffstats
path: root/HAL-afb/HAL_MOST_UNICENS/ucs2-vol/src/CMakeLists.txt
diff options
context:
space:
mode:
authorFulup Ar Foll <fulup@iot.bzh>2017-08-16 16:35:20 +0200
committerGitHub <noreply@github.com>2017-08-16 16:35:20 +0200
commitba709f088f5a4718b7096003ab19083af4681155 (patch)
treee2eefecdcfcac5b4193e47d2dc9b7bc96c8ede2a /HAL-afb/HAL_MOST_UNICENS/ucs2-vol/src/CMakeLists.txt
parent4ca8fd4015479fa758a789d137a693c30fec8cae (diff)
parentb5e786d60f3fda609a7c66bcbf258137d08e040b (diff)
Merge pull request #5 from tjahnk/create_hal_unicens
Introducing HAL MOST UNICENS
Diffstat (limited to 'HAL-afb/HAL_MOST_UNICENS/ucs2-vol/src/CMakeLists.txt')
-rw-r--r--HAL-afb/HAL_MOST_UNICENS/ucs2-vol/src/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/HAL-afb/HAL_MOST_UNICENS/ucs2-vol/src/CMakeLists.txt b/HAL-afb/HAL_MOST_UNICENS/ucs2-vol/src/CMakeLists.txt
new file mode 100644
index 0000000..1be7184
--- /dev/null
+++ b/HAL-afb/HAL_MOST_UNICENS/ucs2-vol/src/CMakeLists.txt
@@ -0,0 +1,39 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(ucs2-volume)
+
+# Define targets source files
+ADD_LIBRARY(${TARGET_NAME} STATIC device_container.cpp device_value.cpp libmostvolume.cpp setup.cpp)
+
+ # Library properties
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ # Library dependencies from PKG_REQUIRED_LIST
+ #TARGET_LINK_LIBRARIES(ucs2-volume # Library dependencies (include updates automatically)
+ # ${link_libraries}
+ #)
+
+ # Define properties to expose when others use this target
+ TARGET_INCLUDE_DIRECTORIES(${TARGET_NAME}
+ PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}/../inc
+ )
+