summaryrefslogtreecommitdiffstats
path: root/cfg/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Jahnke <tobias.jahnke@microchip.com>2018-09-21 13:17:08 +0200
committerTobias Jahnke <tobias.jahnke@microchip.com>2018-12-18 10:24:00 +0100
commita3806abc3eefd2e6b8726ace474447657cb1e4e3 (patch)
treeacbb45804023500b04b1191bd2250c553fb8d140 /cfg/CMakeLists.txt
parent1d77128c2b1c4e99306f37cc5b8150c250271ee5 (diff)
Add basic source and configuration files
Signed-off-by: Tobias Jahnke <tobias.jahnke@microchip.com>
Diffstat (limited to 'cfg/CMakeLists.txt')
-rw-r--r--cfg/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/cfg/CMakeLists.txt b/cfg/CMakeLists.txt
new file mode 100644
index 0000000..1bf4320
--- /dev/null
+++ b/cfg/CMakeLists.txt
@@ -0,0 +1,31 @@
+###########################################################################
+# Copyright 2017, 2018 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+##################################################
+# Control Policy Config file
+##################################################
+PROJECT_TARGET_ADD(4a-hal-cfg-unicens)
+
+ file(GLOB CONF_FILES "*.json")
+
+ add_input_files("${CONF_FILES}")
+
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "BINDING-CONFIG"
+ OUTPUT_NAME ${TARGET_NAME}
+ )