summaryrefslogtreecommitdiffstats
path: root/HAL-afb/Scarlett-Focusrite/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'HAL-afb/Scarlett-Focusrite/CMakeLists.txt')
-rw-r--r--HAL-afb/Scarlett-Focusrite/CMakeLists.txt38
1 files changed, 0 insertions, 38 deletions
diff --git a/HAL-afb/Scarlett-Focusrite/CMakeLists.txt b/HAL-afb/Scarlett-Focusrite/CMakeLists.txt
deleted file mode 100644
index d2a1742..0000000
--- a/HAL-afb/Scarlett-Focusrite/CMakeLists.txt
+++ /dev/null
@@ -1,38 +0,0 @@
-###########################################################################
-# Copyright 2015, 2016, 2017 IoT.bzh
-#
-# author: Fulup Ar Foll <fulup@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-
-# Add target to project dependency list
-PROJECT_TARGET_ADD(hal-scalett-usb)
-
- # Define project Targets
- ADD_LIBRARY(${TARGET_NAME} MODULE ScarlettUsbHAL.c)
-
- # Binder exposes a unique public entry point
- SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- PREFIX "afb-"
- LABELS "BINDING"
- LINK_FLAGS ${BINDINGS_LINK_FLAG}
- OUTPUT_NAME ${TARGET_NAME}
- )
-
- # Library dependencies (include updates automatically)
- TARGET_LINK_LIBRARIES(${TARGET_NAME}
- hal-interface
- audio-common
- )