summaryrefslogtreecommitdiffstats
path: root/HAL-afb/hal-most-unicens/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'HAL-afb/hal-most-unicens/CMakeLists.txt')
-rw-r--r--HAL-afb/hal-most-unicens/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/HAL-afb/hal-most-unicens/CMakeLists.txt b/HAL-afb/hal-most-unicens/CMakeLists.txt
index 828614f..784024a 100644
--- a/HAL-afb/hal-most-unicens/CMakeLists.txt
+++ b/HAL-afb/hal-most-unicens/CMakeLists.txt
@@ -16,6 +16,7 @@
# limitations under the License.
###########################################################################
+ADD_SUBDIRECTORY(ucs2-vol)
# Add target to project dependency list
PROJECT_TARGET_ADD(hal-most-unicens)
@@ -39,4 +40,9 @@ PROJECT_TARGET_ADD(hal-most-unicens)
# installation directory
INSTALL(TARGETS ${TARGET_NAME}
- LIBRARY DESTINATION ${BINDINGS_INSTALL_DIR}) \ No newline at end of file
+ LIBRARY DESTINATION ${BINDINGS_INSTALL_DIR})
+
+ # Define properties to expose when others use this target
+ TARGET_INCLUDE_DIRECTORIES(${TARGET_NAME}
+ PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}/ucs2-vol/inc
+ )