summaryrefslogtreecommitdiffstats
path: root/HighLevel-afb/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'HighLevel-afb/CMakeLists.txt')
-rw-r--r--HighLevel-afb/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/HighLevel-afb/CMakeLists.txt b/HighLevel-afb/CMakeLists.txt
new file mode 100644
index 0000000..de59686
--- /dev/null
+++ b/HighLevel-afb/CMakeLists.txt
@@ -0,0 +1,40 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(audio-afb)
+
+ # Define project Targets
+ ADD_LIBRARY(audio-afb MODULE HighLevelApiConf.c HighLevelBinding.c)
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(audio-afb PROPERTIES
+ PREFIX ""
+ LINK_FLAGS "-Wl,--version-script=${CMAKE_SOURCE_DIR}/export.map"
+ OUTPUT_NAME audio-highlevel-binding
+ )
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(audio-afb
+ audio-interface
+ ${link_libraries}
+ )
+
+ # installation directory
+ INSTALL(TARGETS audio-afb
+ LIBRARY DESTINATION ${binding_install_dir})