aboutsummaryrefslogtreecommitdiffstats
path: root/AlsaSound/HALayer/CMakeLists.txt
diff options
context:
space:
mode:
authorFulup Ar Foll <fulup@iot.bzh>2017-03-09 15:58:04 +0100
committerFulup Ar Foll <fulup@iot.bzh>2017-03-09 15:58:04 +0100
commit5cb52e556fed8eb0cf74d1052fe413fbb7406b0e (patch)
tree80965e8ad49b5191b200b6bbb1241c4718a0c000 /AlsaSound/HALayer/CMakeLists.txt
parenta237499e8c2e2a045ae3eea0b9a4aaac12032e81 (diff)
Syncup Status with Microchip
Diffstat (limited to 'AlsaSound/HALayer/CMakeLists.txt')
-rw-r--r--AlsaSound/HALayer/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/AlsaSound/HALayer/CMakeLists.txt b/AlsaSound/HALayer/CMakeLists.txt
new file mode 100644
index 0000000..0b12f62
--- /dev/null
+++ b/AlsaSound/HALayer/CMakeLists.txt
@@ -0,0 +1,26 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+PROJECT(hadware-abstraction-layer C)
+
+# Fulup NOTE: this might have to be change for a formal static/dynamic lib
+set(halsharedlib ${CMAKE_CURRENT_SOURCE_DIR}/Shared/SharedHalLib.c)
+
+ADD_SUBDIRECTORY(IntelHda)
+ADD_SUBDIRECTORY(Shared)
+