aboutsummaryrefslogtreecommitdiffstats
path: root/HAL-afb/hal-most-unicens/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Jahnke <tjahnk@users.noreply.github.com>2017-08-04 19:06:08 +0200
committerTobias Jahnke <tjahnk@users.noreply.github.com>2017-08-16 16:00:50 +0200
commitb046f9ef9071c2a22f62b8eed34ccb25266c54ea (patch)
tree046b283da14964c9862e4fa7665c030f82f8a2a7 /HAL-afb/hal-most-unicens/CMakeLists.txt
parent5d4ac3aebd5f269ced0cd6f572090ad1c927e5be (diff)
adds HAL for MOST/UNICENS
Diffstat (limited to 'HAL-afb/hal-most-unicens/CMakeLists.txt')
-rw-r--r--HAL-afb/hal-most-unicens/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/HAL-afb/hal-most-unicens/CMakeLists.txt b/HAL-afb/hal-most-unicens/CMakeLists.txt
new file mode 100644
index 0000000..ed49f1b
--- /dev/null
+++ b/HAL-afb/hal-most-unicens/CMakeLists.txt
@@ -0,0 +1,42 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(hal-most-unicens)
+
+ # Define project Targets
+ ADD_LIBRARY(hal-most-unicens MODULE hal_most_unicens.c)
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ PREFIX "afb-"
+ LABELS "BINDING"
+ LINK_FLAGS ${BINDINGS_LINK_FLAG}
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ hal-interface
+ audio-interface
+ )
+
+ # installation directory
+ INSTALL(TARGETS ${TARGET_NAME}
+ LIBRARY DESTINATION ${BINDINGS_INSTALL_DIR}) \ No newline at end of file