aboutsummaryrefslogtreecommitdiffstats
path: root/conf.d/ctl-rules/CMakeLists.txt
diff options
context:
space:
mode:
authorfulup <fulup.arfoll@iot.bzh>2017-08-13 16:50:34 +0200
committerfulup <fulup.arfoll@iot.bzh>2017-08-13 17:31:30 +0200
commit9777a02c7540fdec145feb948b4bbf1cd44c3352 (patch)
tree85f64445ef292938839092696c449d1b7c63216e /conf.d/ctl-rules/CMakeLists.txt
parentb65178642727536972d0c04e53b2310be58beb2e (diff)
Fix AFB_MESSAGE with null arguments
Diffstat (limited to 'conf.d/ctl-rules/CMakeLists.txt')
-rw-r--r--conf.d/ctl-rules/CMakeLists.txt44
1 files changed, 0 insertions, 44 deletions
diff --git a/conf.d/ctl-rules/CMakeLists.txt b/conf.d/ctl-rules/CMakeLists.txt
deleted file mode 100644
index 51a3a46..0000000
--- a/conf.d/ctl-rules/CMakeLists.txt
+++ /dev/null
@@ -1,44 +0,0 @@
-###########################################################################
-# Copyright 2017 IoT.bzh
-#
-# author: Fulup Ar Foll <fulup@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-
-##################################################
-# Control Policy Config file
-##################################################
-PROJECT_TARGET_ADD(control-rules)
-
- file(GLOB XML_FILES "*.json" "*.lua")
-
- add_custom_target(${TARGET_NAME}
- DEPENDS ${PROJECT_PKG_BUILD_DIR}/${TARGET_NAME}
- )
-
- # check XML schema before pushing config
- add_custom_command(
- DEPENDS ${XML_FILES}
- OUTPUT ${PROJECT_PKG_BUILD_DIR}/${TARGET_NAME}
- # COMMAND xmllint -schema ${XML_SCHEMA} ${XML_FILES} --noout (Fulup we miss this for JSON)
- COMMAND mkdir -p ${PROJECT_PKG_BUILD_DIR}/${TARGET_NAME}
- COMMAND touch ${PROJECT_PKG_BUILD_DIR}/${TARGET_NAME}
- COMMAND cp -r ${XML_FILES} ${PROJECT_PKG_BUILD_DIR}/${TARGET_NAME}
- )
-
- SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- LABELS "DATA"
- OUTPUT_NAME ${TARGET_NAME}
- )